





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="3786409" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=655b45577bf044b1307230428ca22421" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=655b45577bf044b1307230428ca22421" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=655b45577bf044b1307230428ca22421" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=655b45577bf044b1307230428ca22421" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: Whole Site" href="http://www.connectsavannah.com/savannah/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: News &amp; Opinion Section" href="http://www.connectsavannah.com/savannah/Rss.xml?oid=2130481" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: News Feed" href="http://www.connectsavannah.com/savannah/Rss.xml?oid=2172813" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: Comments on News Feed" href="http://www.connectsavannah.com/savannah/Rss.xml?id=comments&amp;oid=2172813" />
      
    
  

  
  <script src="/foundation/scripts/core-public.js?cb=c7258dfcfd"></script>

  
  

  
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.connectsavannah.com\/savannah\/Profile", "http:\/\/posting.connectsavannah.com\/savannah\/MyProfile");
  </script>
  
  
  

  
  
  
    
  

  
  <link href='http://fonts.googleapis.com/css?family=Oswald:400,700' rel='stylesheet' type='text/css'>


<!-- Google Publisher Tag Header -->
<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
<!-- End Google Publisher Tag Header -->





<meta name="google-site-verification" content="krma5BtZyoN-CggKO0A_yRuVb9edPfhgecdqXbuMjNU" />
  
  
  
  
  

  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Molly Shannon, &quot;Luke Cage&quot; star Mahershala Ali among honorees for Savannah Film Festival | News Feed" />
  <meta name="description" content="SCAD has announced its honorees and guests for the 2016 Film Festival.&amp;nbsp; Mahershala Ali will receive the Discovery Award on Fri., Oct. 28 and will..." />
  <meta name="keywords" content="news, politics, opinion, democrat, libertarian, republican, schools, education, government, savannah, events, news, restaurant, arts, music, best of savannah, clubs, gay, food, blogs" />
  <title>Molly Shannon, "Luke Cage" star Mahershala Ali among honorees for Savannah Film Festival | News Feed</title>

  
  
  
    <meta name="author" content="Jim Morekis">
  

  
  
  <meta name="news_keywords" content="news, politics, opinion, democrat, libertarian, republican, schools, education, government, savannah" />

  
  
    
  
  
    <link rel="image_src" href="http://media1.fdncms.com/connectsavannah/imager/u/slideshow/3786416/mahershalaalihungergames.jpg" />
    <meta name="thumbnail" content="http://media1.fdncms.com/connectsavannah/imager/u/slideshow/3786416/mahershalaalihungergames.jpg" />
  

  
    
      <link rel="canonical" href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival" />
      
    

    
    
    
  

  
    
      <meta property="og:url" content="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival" />
    
  

  
    <meta property="fb:app_id" content="132533453593784" />
  

  
  <meta property="og:site_name" content="Connect Savannah" />
  <meta property="og:title" content="Molly Shannon, &quot;Luke Cage&quot; star Mahershala Ali among honorees for Savannah Film Festival" />
 
  
    <meta property="og:image" content="http://media1.fdncms.com/connectsavannah/imager/u/slideshow/3786416/mahershalaalihungergames.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="630" />
      <meta property="og:image:height" content="329" />
    
  

  
  
    <meta property="og:description" content="SCAD has announced its honorees and guests for the 2016 Film Festival.&amp;nbsp; Mahershala Ali will receive the Discovery Award on Fri., Oct. 28 and will..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">3786409</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20161014131509</Attribute>
        <Attribute name="creationdate">20161014121738</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20161014123000</Attribute>
            <Attribute name="releasedate">20161014</Attribute>
            <Attribute name="releaseepoch">1476462600</Attribute>
            <Attribute name="title">Molly Shannon, &quot;Luke Cage&quot; star Mahershala Ali among honorees for Savannah Film Festival</Attribute>
            <Attribute name="author">2130581</Attribute>
            <Attribute name="authorname">Jim Morekis</Attribute>
            <Attribute name="authorsortname">Morekis, Jim</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.connectsavannah.com\/NewsFeed\/archives\/2016\/10\/14\/luke-cage-star-among-honorees-for-savannah-film-festival"
          },
          "headline": "Molly Shannon, \"Luke Cage\" star Mahershala Ali among honorees for Savannah Film Festival",
          
            "description": "SCAD has announced its honorees and guests for the 2016 Film Festival.&nbsp;",
          
          
            "image": {
              "url": "http:\/\/media1.fdncms.com\/connectsavannah\/imager\/u\/original\/3786416\/mahershalaalihungergames.jpg",
              "width": 656,
              "height": 343,
              "@type": "ImageObject"
            },
          
          "datePublished": "2016-10-14T12:30:00Z",
          "dateModified": "2016-10-14T13:15:09Z",
          
            "author": {
              "name": "Jim Morekis",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Connect Savannah",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.connectsavannah.com\/imager\/b\/google-amp-logo\/808579\/d74b\/Connect-logo_tagline-250x250.jpg",
                "width": 250,
                "height": 250,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "http://schema.org",
          "@type": "BlogPosting"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="http://media1.fdncms.com/connectsavannah/imager/u/slideshow/3786416/mahershalaalihungergames.jpg">

    
    

    
      <meta name="twitter:creator" content="@jimmorekis">
    

    <meta name="twitter:site" content="@ConnectSavannah">
    <meta name="twitter:title" content="Molly Shannon, &quot;Luke Cage&quot; star Mahershala Ali among honorees for Savannah Film Festival">
    <meta name="twitter:description" content="SCAD has announced its honorees and guests for the 2016 Film Festival.&amp;nbsp; Mahershala Ali will receive the Discovery Award on Fri., Oct. 28 and will...">
  
</head>





  <body id="Post" class="BlogPost Iapetus10Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="http://m.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  



<div id="HeaderLogin" class="GlobalHeader BlogPost ">

  <div class="topLinks">

  
  
  
  
    <div id="loggingModule">
      
      <ul data-view="loggedin" style="display:none">
        <li><strong data-label="username">Username</strong> | </li>
        <li><a href="http://posting.connectsavannah.com/savannah/MyProfile">View Profile</a> | </li>
        <li><a href="http://posting.connectsavannah.com/savannah/Profile/MySettings">Edit Profile</a> | </li>
        <li><a href="http://www.connectsavannah.com/savannah/Logout">Log Out</a></li>
      </ul>

      <ul data-view="loggedout" style="display:none">
        <li><a href="#LogIn">Log in</a> | </li>
        <li><a href="#CreateAccount">Create Account</a></li>
      </ul>
    </div><!-- #loggingModule -->
  

  <ul id="socialLinking">
    <li><a href="http://www.connectsavannah.com/savannah/Newsletter" id="newsletters" title="Newsletters">Newsletters</a> | </li>
    <li>Follow Us:</li>
    <li><a href="https://www.facebook.com/connectsav" id="facebook" target="_blank" title="Facebook">Facebook</a></li>
    <li><a href="https://twitter.com/ConnectSavannah" id="twitter" target="_blank" title="Twitter">Twitter</a></li>
    <li><a href="https://plus.google.com/108091565665393451405" rel="publisher" id="googleplus" target="_blank" title="Google Plus">Google+</a></li>
    <li><a href="http://instagram.com/connectsavannah#" id="instagram" target="_blank" title="Instagram">Instagram</a></li>
    <li><a href="http://www.pinterest.com/connectsavannah/pins/" id="pinterest" target="_blank" title="Pinterest">Pinterest</a></li>
    <li><a href="http://www.youtube.com/user/connectsavannah/videos" id="youtube" target="_blank" title="YouTube">YouTube</a></li>
    <li><a href="http://www.connectsavannah.com/savannah/Syndication" id="rss" title="RSS">RSS</a> | </li>
    <li><a href="http://m.connectsavannah.com/savannah/Home" id="mobile" title="Mobile">Mobile</a></li>
    <li id="headerSearch">
        
        
        <form class="prepTextForm" id="searchbox_017793458706336421686:fnzbo7q7j30" action="http://www.connectsavannah.com/savannah/Search">
            <input type="hidden" name="cx" value="017793458706336421686:fnzbo7q7j30" />
            <input type="hidden" name="cof" value="FORID:9" />
            <input type="text" name="q" size="25" value="Search Connect Savannah..."  onFocus="this.value=''"/>
            <input type="submit" name="sa" value="go" />
        </form>
      
    </li>
  </ul>
  
  </div><!-- .topLinks -->
  
  <div id="leaderBoard" class="Ad Leaderboard">
    <!-- /21599337/leaderboard_1_728x90 -->
          <div id="div-gpt-ad-leaderboard_1_728x90" style="" data-slot="/21599337/leaderboard_1_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-leaderboard_1_728x90');
                });
            </script>
          </div>
  </div>

  
     <div id="logo"><a href="http://www.connectsavannah.com/">Connect Savannah</a></div>
  

</div><!-- #HeaderLogin -->



  <script>
    new Foundation.LoginRequiredComponent("HeaderLogin");
  </script>
















<div id="NavigationHorizontal" class="GlobalHeader BlogPost ">
  <!--xxx-remove Today: 2016-10-14 04:00:00 -->
  

  
  <script>
  "use strict";
    function revealPanel(hoverSelector,clickSelector,panelSelector,alignSelector){
      var focusPanel = function(e){
        if(alignSelector){
          var leftPos = Math.round(jQuery(alignSelector).position().left);
          var panelWidth = jQuery(panelSelector).outerWidth();
          var remainingWidth = window.innerWidth - jQuery(alignSelector).parent().outerWidth()
          var rightBound = leftPos + panelWidth + remainingWidth/2;
          if(rightBound > window.innerWidth){
            leftPos = leftPos - (rightBound - window.innerWidth) - 10;
          }
          jQuery(panelSelector).css('left',leftPos+'px');
        }
        jQuery(hoverSelector).off('hover', focusPanel);
        jQuery(document).on('mousemove', blurPanel);
        jQuery(panelSelector).show();
      }
      var focusPanelTillClickAway = function(e){
        if(alignSelector){
          var leftPos = Math.round(jQuery(alignSelector).position().left);
          var panelWidth = jQuery(panelSelector).outerWidth();
          var remainingWidth = window.innerWidth - jQuery(alignSelector).parent().outerWidth()
          var rightBound = leftPos + panelWidth + remainingWidth/2;
          if(rightBound > window.innerWidth){
            leftPos = leftPos - (rightBound - window.innerWidth) - 10;
          }
          jQuery(panelSelector).css('left',leftPos+'px');
        }
        jQuery(hoverSelector).off('hover', focusPanel);
        jQuery(document).off('mousemove', blurPanel);
        jQuery(document).on('click', blurPanel);
        jQuery(panelSelector).show();
      }
      var blurPanel = function(e){
        // 
        // 
        if((e.which <= 1 && jQuery(e.target).closest(panelSelector+", "+hoverSelector+", "+clickSelector).length === 0) 
           || e.which == 27) {
          jQuery(document).off('mousemove click', blurPanel);
          resetPanel();
          jQuery(panelSelector).hide();
        }
      }
      var resetPanel = function(){
        if(hoverSelector != ''){
          jQuery(hoverSelector).on('hover',focusPanel);
        }
        if(clickSelector != ''){
          jQuery(clickSelector).on('click',focusPanelTillClickAway);
        }
      }
      // init stuff
      resetPanel();
      jQuery(document).on('keydown', blurPanel);
    }
  </script>

  
  
      <ul id="mainNav">
    
    

    

    

    

    <li class="first navCurrent" id="NavItem_NewsOpinion">
      <a href="http://www.connectsavannah.com/savannah/news-and-opinion/Section?oid=2130481" target="_self" class="subnav_link" id="SNAVL_NewsOpinion">News &amp; Opinion</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_ArtsEntertainment">
      <a href="http://www.connectsavannah.com/savannah/arts-and-entertainment/Section?oid=2130484" target="_self" class="subnav_link" id="SNAVL_ArtsEntertainment">Arts &amp; Entertainment</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_MusicClubs">
      <a href="http://www.connectsavannah.com/savannah/music-and-clubs/Section?oid=2130482" target="_self" class="subnav_link" id="SNAVL_MusicClubs">Music &amp; Clubs</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_FoodDrink">
      <a href="http://www.connectsavannah.com/savannah/food-and-drink/Section?oid=2130486" target="_self" class="subnav_link" id="SNAVL_FoodDrink">Food &amp; Drink</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_Film">
      <a href="http://www.connectsavannah.com/savannah/film/Section?oid=2130483" target="_self" class="subnav_link" id="SNAVL_Film">Film</a>
    </li>

    
  
    

    

    

    

    <li class="last" id="NavItem_Calendar">
      <a href="http://www.connectsavannah.com/savannah/EventSearch" target="_self" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
    </li>

    
  
      </ul>
    

  
    
    
      
        <h3 class="hidden">Browse News &amp; Opinion</h3>
        <div class="subnav_content" id="SNAV_NewsOpinion" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/editors-note-disastrous-leadership/Content?oid=3778972">Editor's Note: Disastrous leadership?</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/matthew-confirms-resiliency-of-oglethorpes-plan/Content?oid=3778976">Matthew confirms resiliency of Oglethorpe’s plan</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/should-we-stay-or-should-we-go/Content?oid=3778973">Should we stay or should we go?</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/silent-no-more/Content?oid=3766601">Safe Shelter remembers local victims of domestic violence</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/an-unholy-tour/Content?oid=3766597">Sex trafficking's unholy tour</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130481" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/editors-note/Category?oid=2130530" target="_self" title="">Editors Note</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/letters/Category?oid=2130495" target="_self" title="">Letters</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/blotter/Category?oid=2130505" target="_self" title="">Blotter</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/the-civil-society-column/Category?oid=2130535" target="_self" title="">The (Civil) Society Column</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/environment/Category?oid=2130494" target="_self" title="">Environment</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/politics/Category?oid=2130497" target="_self" title="">Politics</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/community/Category?oid=2130499" target="_self" title="">Community</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/city-notebook/Category?oid=2130502" target="_self" title="">City Notebook</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/news-cycle/Category?oid=2130534" target="_self" title="">News Cycle</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Food &amp; Drink</h3>
        <div class="subnav_content" id="SNAV_FoodDrink" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/butterhead-greens-has-found-its-niche/Content?oid=3766595">Butterhead Greens  has found its niche</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/food-truck-fest-20/Content?oid=3766610">Food Truck Fest 2.0</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/kitchen-320-defies-expectations/Content?oid=3766624">Kitchen 320  defies expectations</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/our-daily-bread-showcases-kentucky-hot-browns-and-nycs-cronuts/Content?oid=3753737">Our Daily Bread showcases Kentucky Hot Browns and NYC’s Cronuts</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/blowin-smoke-blows-it-away/Content?oid=3753733">Blowin' Smoke blows it away</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130486" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/food-news/Category?oid=2136875" target="_self" title="">Food News</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationSection=2124351" target="_self" title="">Restaurants</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationSection=2170847" target="_self" title="">Bars &amp; Clubs</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/LocationUpdateorAdditionRequest/Page?Subject=Addition" target="_self" title="">Submit Your Bar or Restaurant</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Music &amp; Clubs</h3>
        <div class="subnav_content" id="SNAV_MusicClubs" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/clay-hodges-aphelion/Content?oid=3778975">Clay Hodges + Aphelion</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/jamie-herbsters-musical-therapy/Content?oid=3778978">Jamie Herbster’s musical therapy</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/the-worlds-second-smallest-music-festival/Content?oid=3778983">The World’s Second Smallest Music Festival</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/duotour-ii-in-the-c-port-sulfur-studios/Content?oid=3766604">Duotour II in the C-Port @Sulfur Studios</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/clap-your-hands-say-yeah-private-living-room/Content?oid=3766599">Clap Your Hands Say Yeah @Private Living Room</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130482" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/interview/Category?oid=2130513" target="_self" title="">Interviews</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/music-features/Category?oid=2130532" target="_self" title="">Features</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="savannah/EventSearch?eventSection=2129642" target="_self" title="">Soundboard Listings</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationCategory=2124596" target="_self" title="">Music Venues</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/LocationUpdateorAdditionRequest/Page?Subject=Addition" target="_self" title="">Submit Your Music Venue</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Arts &amp; Entertainment</h3>
        <div class="subnav_content" id="SNAV_ArtsEntertainment" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/are-you-experienced-enter-the-world-of-savannahs-own-lavender-mist/Content?oid=3778982">Enter the world of Savannah’s own Lavender Mist</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/savannah-stage-company-shows-its-gothic-side/Content?oid=3766645">Savannah Stage Company shows its Gothic side</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/welcome-to-the-slotherhouse/Content?oid=3766642">Welcome to the Slotherhouse!</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/a-greek-festival-with-international-flavor/Content?oid=3766618">A Greek Festival with international flavor</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/armstrong-keeps-it-short-and-silly-in-shakespeare-tribute/Content?oid=3753420">The soul of wit: Armstrong keeps it short and silly in Shakespeare tribute</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130484" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/theatre/Category?oid=2130508" target="_self" title="">Theatre</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/visual-arts/Category?oid=2130509" target="_self" title="">Visual Arts</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/dance/Category?oid=2130510" target="_self" title="">Dance</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/books/Category?oid=2130511" target="_self" title="">Books</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/culture/Category?oid=2130496" target="_self" title="">Culture</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2130134" target="_self" title="">Art Patrol</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Film</h3>
        <div class="subnav_content" id="SNAV_Film" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-the-accountant/Content?oid=3786413">Review: The Accountant</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/savannah-film-festival-announces-movie-lineup/Content?oid=3760040">Savannah Film Festival announces movie lineup</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-masterminds/Content?oid=3760083">Review: Masterminds</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-the-magnificent-seven/Content?oid=3746455">Review: The Magnificent Seven</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130483" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/local-film/Category?oid=2130520" target="_self" title="">Local Film</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/screenshots/Category?oid=2130519" target="_self" title="">Screenshots</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/MovieTimes" target="_self" title="">Movie Times</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Calendar</h3>
        <div class="subnav_content" id="SNAV_Calendar" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              
              
               <li><a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">Pink Floyd Laser Show</a></li>               
              
            
              
               <li><a href="http://www.connectsavannah.com/savannah/the-worlds-second-smallest-music-festival/Event?oid=3747365">The World's Second Smallest Music Festival</a></li>               
              
               
               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">Pink Floyd Laser Show</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/lavender-mist-experience/Event?oid=3782390">Lavender Mist Experience</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/step-up-savannah-annual-meeting-and-breakfast/Event?oid=3697704">Step Up Savannah Annual Meeting & Breakfast</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/step-up-savannahs-annual-meeting-and-breakfast/Event?oid=3755676">Step Up Savannah's Annual Meeting and Breakfast</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/2-days-of-donation-based-yoga-were-turning-one/Event?oid=3756010">2 Days of Donation Based Yoga: We're Turning One!</a></li>               
                  
                   
               <li>
                  <a href="http://www.connectsavannah.com/savannah/EventSearch" class="more">(more)</a>
                </li>
                </ul>
              
  
          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=today" target="_self" title="">Connect Today</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Tomorrow" target="_self" title="">Tomorrow</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch" target="_self" title="">Search Events</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=This%20Weekend" target="_self" title="">This Weekend</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Next%207%20Days" target="_self" title="">Next 7 Days</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Next%2030%20Days" target="_self" title="">Next 30 Days</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2130134" target="_self" title="">Art Patrol</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2129641" target="_self" title="">Happenings</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="savannah/EventSearch?eventSection=2129642" target="_self" title="">Soundboard</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?feature=Week%20at%20a%20Glance" target="_self" title="">Week at a Glance</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/Events/AddEvent" target="_self" title="">Submit Event</a>
          </li>

          
          </ul>
        </div>
      
    

    
    
      <script>
      (function(){
        jQuery('#NavigationHorizontal .subnav_link').parent().each(function(){
          var navigationID = jQuery(this).attr('id');
          if(navigationID){
            var navigationSelector = '#NavigationHorizontal #'+navigationID;
            var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
            revealPanel(navigationSelector, '', navMenuSelector, navigationSelector);
          }
        });
      })();
      </script>
    
  
  
</div><!-- End #NavigationHorizontal -->








<div id="SecondaryNavigation" class="GlobalHeader BlogPost ">

  
  

  
    
        <ul id="mainNavSN">
      
      

      

      

      

      <li class="first secondary" id="NavItem_BestOfSavannah">
        <a href="http://www.connectsavannah.com/savannah/BestOf" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_BestOfSavannah">Best Of Savannah</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_SpecialIssues">
        <a href="http://www.connectsavannah.com/savannah/special-issues/Section?oid=2136902" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_SpecialIssues">Special Issues</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Extras">
        <a href="http://www.connectsavannah.com/savannah/extras/Section?oid=2130487" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_Extras">Extras</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_AboutUs">
        <a href="http://www.connectsavannah.com/savannah/AboutUs/Page" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_AboutUs">About Us</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Archives">
        <a href="http://www.connectsavannah.com/savannah/IssueArchives" target="_self" class="mainNavAnchor">Archives</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Media">
        <a href="http://www.connectsavannah.com/savannah/VideoArchives" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_Media">Media</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Classifieds">
        <a href="http://www.verican.us/cod6/connectsavannah" target="_blank" class="mainNavAnchor">Classifieds</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_FreeStuff">
        <a href="http://www.connectsavannah.com/savannah/freestuff" target="_self" class="mainNavAnchor">Free Stuff</a>
      </li>

      
    
      

      

      

      

      <li class="last secondary" id="NavItem_App">
        <a href="http://connectsavannah.saambaa.com/apps/savannah.html" target="_self" class="mainNavAnchor">App</a>
      </li>

      
    
        </ul>
      

    
      
      
        
          <h3 class="hidden">Browse Best Of Savannah</h3>
          <div class="subnav_content subNavSN" id="SECNAV_BestOfSavannah" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130524" target="_self" title="">Music &amp; Culture</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130522" target="_self" title="">City Life &amp; Public Affairs</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130533" target="_self" title="">Media</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130525" target="_self" title="">Food &amp; Restaurants</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130526" target="_self" title="">Nightlife &amp; Drink</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130527" target="_self" title="">Recreation, Health &amp; Beauty</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130528" target="_self" title="">Shopping &amp; Services</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Special Issues</h3>
          <div class="subnav_content subNavSN" id="SECNAV_SpecialIssues" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf" target="_self" title="">The Best of Savannah Issue</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/st-patricks-day/Category?oid=2136903" target="_self" title="">Saint Patrick&rsquo;s Day Issue</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/savannah-music-festival/Category?oid=2130517" target="_self" title="">Savannah Music Festival Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/savannah-film-festival/Category?oid=2172814" target="_self" title="">Savannah Film Festival Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/fall-arts-issue/Category?oid=3716959" target="_self" title="">Fall Arts Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/savannah-craft-brew-fest/Category?oid=3698397" target="_self" title="">Savannah Craft Brew Fest Issue</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Extras</h3>
          <div class="subnav_content subNavSN" id="SECNAV_Extras" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/the-ghost-dog-diaries/Category?oid=2520837" target="_self" title="">The Ghost Dog Diaries</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/crosswords/Content?category=2130529" target="_self" title="">Crossword</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/the-straight-dope/Category?oid=2130504" target="_self" title="">Straight Dope</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/friends2follow/Page" target="_self" title="">friends2follow</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse About Us</h3>
          <div class="subnav_content subNavSN" id="SECNAV_AboutUs" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/Advertising/Page" target="_self" title="">Advertising</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/AdSizes/Page" target="_self" title="">Ad Specs &amp; Sizes</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/ContactUs/Page" target="_self" title="">Contact Us</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/LocationSearch?feature=CS%20Pickup%20Locations" target="_self" title="">Find A Paper</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/Jobs/Page" target="_self" title="">Jobs</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/SubmissionGuidelines/Page" target="_self" title="">Submission Guidelines</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Media</h3>
          <div class="subnav_content subNavSN" id="SECNAV_Media" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="">
              <a href="savannah/VideoArchives" target="_self" title="">Videos</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/Slideshows/Page" target="_self" title="">Photo Galleries</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2138545" target="_self" title="">Media Archives</a>
            </li>

            
            </ul>
          </div>
        

      
    

    
      <script>
      (function(){
        jQuery('#SecondaryNavigation .sec_subnav_link').parent().each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#SecondaryNavigation #'+navigationID;
          var navMenuSelector = '#SecondaryNavigation #SECNAV_'+navigationID.split('_')[1];
          revealPanel(navigationSelector, '', navMenuSelector, navigationSelector);
        });
      })();
      </script>
    

  
</div><!-- end navigation -->
<div id="Pencil1" class="GlobalHeader BlogPost Ad Pencil">
  <!-- /21599337/pencil_1_975x35 -->
          <div id="div-gpt-ad-pencil_1_975x35" style="" data-slot="/21599337/pencil_1_975x35" data-output="asynchronous" data-width="975" data-height="35">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-pencil_1_975x35');
                });
            </script>
          </div>
</div><!-- #Pencil1 -->
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        


  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost   NewsFeed">
    <a href="http://www.connectsavannah.com/blogs/NewsFeed/">
    <h1 class="NewsFeed">
      
        News Feed
      
    </h1>
    </a>

    

    <p>
      
        <a href="http://www.connectsavannah.com/savannah/NewsFeed/blogs/Archives">Archives</a> |
        <a href="/savannah/Rss.xml?category=2172813">RSS</a>
      
      
    </p>
  </div>




  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/savannah-philharmonic-second-harvest-partner-for-hurricane-relief-food-drive" class="prev" rel="prev">&laquo;&nbsp;Savannah Philharmonic, Second Harve&hellip;</a>
    </div>
  </div>








  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="SpanningFeature BlogPost   ">
    
    
    
    
    
    
      
      
        <h2 class="blogDate">Friday, October 14, 2016</h2>
      
    
      
      <div class="blogPost newsfeed ">
    
    
    <h3 class="postTitle" id="a3786409">
      
      
      
      
      
      
        Molly Shannon, "Luke Cage" star Mahershala Ali among honorees for Savannah Film Festival
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        Posted
        
          
          By <a href="http://www.connectsavannah.com/savannah/ArticleArchives?author=2130581" rel="author">Jim Morekis</a>
        
        
          
            on <span class="postTime">Fri, Oct 14, 2016</span> at <span class="postTime">12:30 PM</span>
          
        
      </h4>
    

    
    

    

    
    

    
    

    <div class="postBody">
      
          
      
      
       
      
      
      
      
      
       
      
      

      
      

      
        
        
        
        <div class="contentImageCenter" style="overflow:hidden;">                              <span class="clicktozoom">click to enlarge</span>                <a href="http://media1.fdncms.com/connectsavannah/imager/u/original/3786416/mahershalaalihungergames.jpg" class="zoomable" rel="contentImg_gal-3786409" title="">                  <img src="http://media1.fdncms.com/connectsavannah/imager/u/big/3786416/mahershalaalihungergames.jpg" width="450" height="235" alt="mahershalaalihungergames.jpg" />                </a>                                                                                              <ul style="width:450px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>

SCAD has announced its honorees and guests for the 2016 Film Festival.&nbsp;<br>
<br>
Mahershala Ali will receive the Discovery Award on Fri., Oct. 28 and will participate in a Q&amp;A session after the screening of "Moonlight."&nbsp;Ali can currently be seen starring in Netflix and Marvel Entertainment’s “Luke Cage.” <br>
<br>
Sam Claflin will receive the Spotlight Award on Wed., Oct. 26 and will participate in a Q&amp;A session after the screening of "Me Before You."&nbsp;Claflin’s credits include “The Hunger Games: Catching Fire,” “The Hunger Games: Mockingjay - Part 1,” “The Hunger Games: Mockingjay – Part 2,” “Friday,” and more.&nbsp;<br>
<br>
Molly Shannon will receive the Spotlight Award on Mon., Oct. 24 and will participate in a Q&amp;A session following the screening of "Other People."&nbsp;Shannon spent six seasons as a member of the repertory company on “Saturday Night Live,” and her other credits include “Miles,” “Me &amp; Earl &amp; the Dying Girl,” “Life After Beth,” “Scary Movie 5,” “Hotel Transylvania,” and more.<br>
<br>
Miles Teller will receive the Vanguard Award on Tues., Oct. 25 and will participate in a Q&amp;A session following the screening of "Bleed for This."&nbsp;Teller recently starred in “War Dogs,” alongside Jonah Hill with Todd Phillips directing, and his other credits include “Rabbit Hole,” “That Awkward Moment,” “Divergent,” “Whiplash,” and more.<br>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
        
        















  
  
  

  

  

  
  


        <ul class="horizontalShareTools">
          <li class="l0 first">
            <div style="overflow:hidden;"><fb:like href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div></li> <li class="l0"><a href="http://twitter.com/share?url=http%3A//www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival&text=Molly%20Shannon%2C%20%22Luke%20Cage%22%20star%20Mahershala%20Ali%20among%20honorees%20for%20Savannah%20Film%20Festival" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0">


  

  

  

  <a href="http://pinterest.com/pin/create/button/?description=Molly%20Shannon%2C%20%22Luke%20Cage%22%20star%20Mahershala%20Ali%20among%20honorees%20for%20Savannah%20Film%20Festival&amp;media=http%3A%2F%2Fmedia1.fdncms.com%2Fconnectsavannah%2Fimager%2Fu%2Fslideshow%2F3786416%2Fmahershalaalihungergames.jpg&amp;url=http%3A%2F%2Fwww.connectsavannah.com%2FNewsFeed%2Farchives%2F2016%2F10%2F14%2Fluke-cage-star-among-honorees-for-savannah-film-festival" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("http://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</li> <li class="l0"><a href="http://www.stumbleupon.com/submit?url=http%3A//www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival&title=Molly%20Shannon%2C%20%22Luke%20Cage%22%20star%20Mahershala%20Ali%20among%20honorees%20for%20Savannah%20Film%20Festival" target="_blank" class="toolIconLink"><img src="/binary/620b/stumbleupon-16x16.png" width="16" height="16" alt="" /></a>
    <a href="http://www.stumbleupon.com/submit?url=http%3A//www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival&title=Molly%20Shannon%2C%20%22Luke%20Cage%22%20star%20Mahershala%20Ali%20among%20honorees%20for%20Savannah%20Film%20Festival" target="_blank" class="toolTextLink">StumbleUpon</a></li> <li class="l0">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="http://posting.connectsavannah.com/savannah/Profile/MyFavorites?add=3786409">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="3786409" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</li> <li class="l0">

<a class="emailAction" title="Email" href="http://posting.connectsavannah.com/savannah/Tools/EmailFriend?oid=3786409" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</li> <li class="l0">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-5137aa00327268d3" addthis:url="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival" addthis:title="Molly Shannon, "Luke Cage" star Mahershala Ali among honorees for Savannah Film Festival" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-5137aa00327268d3", true);
  </script>


          </li>
        </ul>
      
    

    

    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>


<div id="MediumRectangleInterstitial" class="SpanningFeature BlogPost MediumRectangle Ad">
  <!-- /21599337/Inline_1_box_300x250 -->
          <div id="div-gpt-ad-inline_1_box_300x250" style="" data-slot="/21599337/Inline_1_box_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-inline_1_box_300x250');
                });
            </script>
          </div>
</div><!-- #MediumRectangleInterstitial -->




<div id="Taboola" class="SpanningFeature BlogPost clearfix ">
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'http://cdn.taboola.com/libtrc/connectsavannah/loader.js');
</script>
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>



</div>



    
    
    
    



























  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature BlogPost ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2015/11/19/bernie-sanders-to-visit-savannah-this-sunday">Bernie Sanders to visit Savannah this Sunday</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Nov 19, 2015</span>
        </li>
      
    </ul>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2015/05/19/georgia-dot-smacks-down-palmetto-pipeline">Georgia DOT smacks down Palmetto Pipeline</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 19, 2015</span>
        </li>
      
    </ul>
  </li>
      
      
    
          </ul>
        </div>
      
               






  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature BlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="3786409" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/savannah/Rss.xml?id=comments&amp;oid=3786409" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:false}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="3786409" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  






  

      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          

<script type="text/javascript">
  function setBioLink(){
    jQuery(".bio .readMore").click(function(e){
      e.preventDefault();
      var elem = jQuery(this);
      if (elem.prevAll(".authorBioLong").is(":hidden")){
        elem.prevAll(".authorBioShort").fadeOut("fast", function(){
          elem.prevAll(".authorBioLong").fadeIn("fast");
          elem.html("less");
        });          
      } else {
        elem.prevAll(".authorBioLong").fadeOut("fast", function(){
          elem.prevAll(".authorBioShort").fadeIn("fast");                   
          elem.html("more");
        });          
      }
    })
  }
</script>


<script>setBioLink();</script>






  
  
      <div id="LatestInCategory" class="MainColumn1 BlogPost ">
        <h3 class="latestnews_feed"><span class="headingText">Latest in News Feed</span></h3>
        <ul class="moduleList">
    
    
    <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/savannah-philharmonic-second-harvest-partner-for-hurricane-relief-food-drive">Savannah Philharmonic, Second Harvest partner for hurricane relief food drive</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 14, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
    
    <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/12/hurricane-forces-cancellations-rescheduling-of-events">Hurricane forces cancellations, rescheduling of events</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 12, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
    
    <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/12/curfew-lifted-throughout-chatham-county">Curfew lifted throughout Chatham County</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 12, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
         <li class="l0 storyItem more">
           <a href="http://www.connectsavannah.com/savannah/ArticleArchives?category=2172813" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    



        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          





  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn2 BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="MainColumn2 BlogPost ">
            <h3><span class="headingText">More by Jim Morekis</span></h3>
            <ul class="moduleList">
        
        
        
        <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/savannah-philharmonic-second-harvest-partner-for-hurricane-relief-food-drive">Savannah Philharmonic, Second Harvest partner for hurricane relief food drive</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 14, 2016</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
        
        
        <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/12/hurricane-forces-cancellations-rescheduling-of-events">Hurricane forces cancellations, rescheduling of events</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 12, 2016</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
        
        
        <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/12/curfew-lifted-throughout-chatham-county">Curfew lifted throughout Chatham County</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Jim Morekis</li>
      
      <li class="l1 longOnly">
        <span class="date">Oct 12, 2016</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
             <li class="l0 storyItem more">
               <a href="http://www.connectsavannah.com/savannah/ArticleArchives?author=2130581" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  



        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        


<div id="ConnectToday" class="SpanningIsland BlogPost  clearfix">

  <h2>
    <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=today">
    Connect 
    <span class="today">Today</span>
    <span class="date">
      10.14.2016
    </span>
  </a>
  </h2>

  
  
    

      

    
        <ul id="connectImages" class="clearfix">
      
      


      

      <li>
        <a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">
         
          <img src="http://media2.fdncms.com/connectsavannah/imager/u/eventteaser/3768963/dark_side.png" 
          alt="Pink Floyd Laser Show" 
          title="Pink Floyd Laser Show" 
          width="140" 
          height="90" />
                             
        </a>
        <a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">
         Pink Floyd Laser Show @ The Wormhole
        </a>
      </li>

      
    
      


      

      <li>
        <a href="http://www.connectsavannah.com/savannah/the-worlds-second-smallest-music-festival/Event?oid=3747365">
         
          <img src="http://media1.fdncms.com/connectsavannah/imager/u/eventteaser/3747364/9af4c800_w2smf_profile.jpg" 
          alt="The World&#39;s Second Smallest Music Festival" 
          title="The World&#39;s Second Smallest Music Festival" 
          width="140" 
          height="90" />
                             
        </a>
        <a href="http://www.connectsavannah.com/savannah/the-worlds-second-smallest-music-festival/Event?oid=3747365">
         The World's Second Smallest Music Festival @ QuoLab
        </a>
      </li>

      
    
        </ul>
      
  

  

  
      <ul id="connectLinks">
    

    

    <li>
      <h4><a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">Pink Floyd Laser Show</a></h4>
      <p>@ The Wormhole &ndash; 
        &hellip;&nbsp;<span class="more">(<a href="http://www.connectsavannah.com/savannah/pink-floyd-laser-show/Event?oid=3695718">more</a>)</span>
      </p>
    </li>

    

  

    

    <li>
      <h4><a href="http://www.connectsavannah.com/savannah/bad-boy-bill-and-richard-vission/Event?oid=3746150">Bad Boy Bill & Richard Vission</a></h4>
      <p>@ Club Elan &ndash; 
        &hellip;&nbsp;<span class="more">(<a href="http://www.connectsavannah.com/savannah/bad-boy-bill-and-richard-vission/Event?oid=3746150">more</a>)</span>
      </p>
    </li>

    

  
      </ul>
    
</div><!-- #ConnectToday -->

<div id="HalfPage1" class="SpanningIsland BlogPost Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_1_300x600 -->
          <div id="div-gpt-ad-halfpage_1_300x600" style="" data-slot="/21599337/halfpage_1_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_1_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage1 -->






<div id="MostReadSharedCommented" class="SpanningIsland BlogPost ">

  <h2 class="tabs">The Most: <a href="#" class="current">Read</a> | <a href="#">Shared</a> | <a href="#">Comments</a></h2>
  <div class="clear"><!-- clear --></div>

  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/editors-note-disastrous-leadership/Content?oid=3778972">Editor's Note: Disastrous leadership?</a></h3>
    
      <p>
      &quot;And you deserve better.&quot; 
Thanks, Jim, for my new campaign slogan.
Murray@

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Murray Silver Jr.</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/matthew-confirms-resiliency-of-oglethorpes-plan/Content?oid=3778976">Matthew confirms resiliency of Oglethorpe’s plan</a></h3>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/should-we-stay-or-should-we-go/Content?oid=3778973">Should we stay or should we go?</a></h3>
    
      <p>
      Go,, please just go.

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Pudbert Savannah GA</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/savannah-philharmonic-second-harvest-partner-for-hurricane-relief-food-drive">Savannah Philharmonic, Second Harvest partner for hurricane relief food drive</a></h3>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/14/luke-cage-star-among-honorees-for-savannah-film-festival">Molly Shannon, "Luke Cage" star Mahershala Ali among honorees for Savannah Film Festival</a></h3>
    
  </li>  
        
    </ul>  
  </div>


  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/jersey-boys-at-the-old-oval-bar/Content?oid=2156646">Jersey boys at the old Oval Bar</a></h3>
    
  </li>
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/editors-note-disastrous-leadership/Content?oid=3778972">Editor's Note: Disastrous leadership?</a></h3>
    
      <p>
      &quot;And you deserve better.&quot; 
Thanks, Jim, for my new campaign slogan.
Murray@

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Murray Silver Jr.</div>
    
  </li>
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2015/05/22/zip-code-change-from-pooler-to-savannah-completed">Zip code change from Pooler to Savannah completed</a></h3>
    
  </li>
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/editors-note-the-money-to-fight-crime-is-out-there/Content?oid=3753739">Editor's Note: The money to fight crime is out there</a></h3>
    
      <p>
      Jim you are a much needed voice in Savannah. Thank you for keeping it real,

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Alys Spillman</div>
    
  </li>
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/22/tourism-leadership-council-issues-statement-on-murder-of-gallery-owner">Tourism Leadership Council issues statement on murder of gallery owner</a></h3>
    
      <p>
      Get rid of these scumbags , heads up everyone Savannah is the new,  New Orl

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Ball of Confusion</div>
    
  </li>
        
    </ul>
  </div>  

  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/editors-note-disastrous-leadership/Content?oid=3778972">Editor's Note: Disastrous leadership?</a></h3>
    
      <p>
      &quot;And you deserve better.&quot; 
Thanks, Jim, for my new campaign slogan.
Murray@

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Murray Silver Jr.</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/editors-note-the-money-to-fight-crime-is-out-there/Content?oid=3753739">Editor's Note: The money to fight crime is out there</a></h3>
    
      <p>
      Jim you are a much needed voice in Savannah. Thank you for keeping it real,

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Alys Spillman</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/24/police-release-new-statement-on-recent-violence">Police release new statement on recent violence</a></h3>
    
      <p>
      They are too busy taking high bid at city clowncil and greasing the palms o

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Mister Jimmy</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/22/scmpd-majors-issue-statement-on-recent-robbery-shootings">SCMPD majors issue statement on recent robbery/shootings</a></h3>
    
      <p>
      Of course &quot;the public&quot; should share information if they have it, but this i

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Mister Jimmy</div>
    
  </li>  
        
        <li>
    <h4>News & Opinion</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/an-unholy-tour/Content?oid=3766597">Sex trafficking's unholy tour</a></h3>
    
      <p>
      PLEASE take your liberal-commie butt BACK up north where you can be around

      <span><a href="http://www.connectsavannah.com">&raquo;</a></span>
      </p>
      <div class="author">Pudbert Savannah GA</div>
    
  </li>  
        
    </ul>
  </div>  

</div>




<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
        $$("#MostReadSharedCommented h2.tabs>a"),
        $$("#MostReadSharedCommented div.commentedBody"),
        "current", "back"
        );

      // Deactivate links.
      $$("#MostReadSharedCommented h2.tabs> a").each(function (a) {
        a.onclick = function () { return false; };
        });
      });
//--></script>










    <div id="RecentComments" class="MainSidebar SpanningIsland BlogPost ">
      <h3><a href="http://www.connectsavannah.com/savannah/CommentArchives?category=2172813&amp;feature=stories&amp;section=2130481">Recent Comments</a></h3>
      <ul class="moduleList">
  
  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/06/mayor-deloach-declares-state-of-local-emergency">Mayor DeLoach declares state of "Local Emergency"</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          If we are in a state of emergency, then why hasn't the City opened Casey&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Murray Silver Jr.</strong>
      </li>
      <li class="l1">
        on October  7, 2016
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/10/07/dusk-to-dawn-curfew-in-force-throughout-storm">Dusk to Dawn Curfew in force throughout storm</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          Good!!
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Tansey4</strong>
      </li>
      <li class="l1">
        on October  7, 2016
        
          <img style="width:14px;height:14px;margin-bottom:-2px;margin-left:2px;" src="/foundation/images/icons/mobile_icon.png"/>
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/30/suspect-arrested-in-yamacraw-shooting">Suspect arrested in Yamacraw shooting</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          He will be roaming the streets by Christmas....freaking thug.
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Ball of Confusion</strong>
      </li>
      <li class="l1">
        on October  3, 2016
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/28/suspect-identified-in-shooting-of-mother-and-child">Suspect identified in shooting of mother and child</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          Again,, he was probably oppressed by whitey....<br>
Call Black THUGS Matter ! !
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Pudbert Savannah GA</strong>
      </li>
      <li class="l1">
        on October  2, 2016
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.connectsavannah.com/NewsFeed/archives/2016/09/30/suspect-arrested-in-yamacraw-shooting">Suspect arrested in Yamacraw shooting</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          He was probably oppressed by whitey...
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Pudbert Savannah GA</strong>
      </li>
      <li class="l1">
        on October  2, 2016
        
      </li>
    </ul>
  </li>

  
  
        <li class="l0 storyItem">
          <a href="http://www.connectsavannah.com/savannah/CommentArchives?category=2172813&amp;feature=stories&amp;section=2130481">More &raquo;</a>
        </li>
      </ul>
    </div>
  

<div id="HalfPage2" class="SpanningIsland BlogPost Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_2_300x600 -->
          <div id="div-gpt-ad-halfpage_2_300x600" style="" data-slot="/21599337/halfpage_2_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_2_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage2 -->







<div id="RightNowonFacebookTwitter" class="SpanningIsland BlogPost ">

  <h2 class="tabs">Right Now On:  <a href="#" class="current">Twitter</a> | <a href="#">Facebook</a> </h2>
  <div class="clear"><!-- clear --></div>

  

  <div class="commentedBody RightNowonFacebookTwitterTwitter" style="display:none">
    <a class="twitter-timeline" href="https://twitter.com/ConnectSavannah" data-widget-id="345218153682440192" data-chrome="noheader nofooter noborders" width="298" height="300">Tweets by @ConnectSavannah</a>
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
  </div>

  

  <div class="commentedBody RightNowonFacebookTwitterFacebook" style="display:none">
    <div class="fb-like-box" data-href="http://www.facebook.com/connectsav" data-width="280" data-height="300" data-show-faces="false" data-stream="true" data-border-color="white" data-header="false" data-force-wall="true"></div>
  </div>

</div>



<script type="text/javascript" src="/foundation/scripts/twitterwidget.js"></script>
<script type="text/javascript">
  function refreshTwitter() {
    getTwitters("RightNowonFacebookTwitter_twitter_div", { 
      id: '', 
      count: 5, 
      enableLinks: true, 
      ignoreReplies: true, 
      clearContents: true,
      template: '%text% <a class="twitterTime" href="http://twitter.com/%user_screen_name%/statuses/%id%/">%time%</a>'
    });
  }
  refreshTwitter();
</script>

<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
        $$("#RightNowonFacebookTwitter h2.tabs>a"),
        $$("#RightNowonFacebookTwitter div.commentedBody"),
        "current", "back"
        );

      // Deactivate links.
      $$("#RightNowonFacebookTwitter h2.tabs> a").each(function (a) {
        a.onclick = function () { return false; };
        });
      });
//--></script>








  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  



<div id="HalfPage3" class="SpanningIsland BlogPost Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_3_300x600 -->
          <div id="div-gpt-ad-halfpage_3_300x600" style="" data-slot="/21599337/halfpage_3_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_3_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage3 --><div id="HalfPage4" class="SpanningIsland BlogPost Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_4_300x600 -->
          <div id="div-gpt-ad-halfpage_4_300x600" style="" data-slot="/21599337/halfpage_4_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_4_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage4 -->
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter BlogPost ">
      <ul>
  
  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/AboutUs/Page" target="_self">
      
        About Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Advertising/Page" target="_self">
      
        Advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/ContactUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Events/AddEvent" target="_self">
      
        Submit An Event
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/LocationSearch?feature=CS%20Pickup%20Locations" target="_self">
      
        Find A Paper
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/ArticleArchives" target="_self">
      
        Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Jobs/Page" target="_self">
      
        Jobs
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/SubmissionGuidelines/Page" target="_self">
      
        Submission Guidelines
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Help/Page" target="_self">
      
        Help
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/PrivacyPolicy/Page" target="_self">
      
        Privacy Policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/newsletter" target="_self">
      
        Newsletters
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
   Copyright &copy; 2016,
   Connect Savannah.
   All Rights Reserved.
   <br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><div id="Leaderboard2" class="GlobalFooter BlogPost Ad Leaderboard">
  <!-- /21599337/leaderboard_2_728x90 -->
          <div id="div-gpt-ad-leaderboard_2_728x90" style="" data-slot="/21599337/leaderboard_2_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-leaderboard_2_728x90');
                });
            </script>
          </div>
</div><!-- #Leaderboard2 --><!-- stats tracking code goes here -->

<!-- Google Analytics -->
	<script type="text/javascript">
	var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
	document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
	</script>
	<script type="text/javascript">
		try {
			var pageTracker = _gat._getTracker("UA-2466088-1");
			pageTracker._trackPageview();
		} catch(err) {}
	</script>
<!--End Google Analytics tag -->	


<!-- Start Quantcast tag -->	

<script type="text/javascript">
var _qevents = _qevents || [];
 
(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();
 
_qevents.push({
qacct:"p-ky3LnQ0LsmzQz"
});
</script>
 
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-ky3LnQ0LsmzQz.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


  <img src="/foundation/images/icons/pixel.gif?oid=3786409" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdFullBackground" class="Closer BlogPost ">
  <!-- /21599337/Site_Skin_1920x900 -->
          <div id="div-gpt-ad-site_skin_1920x900" style="" data-slot="/21599337/Site_Skin_1920x900" data-output="asynchronous" data-width="1920" data-height="900">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-site_skin_1920x900');
                });
            </script>
          </div>
</div><!-- End AdFullBackground -->
















</div><!-- end gridCloser -->
    </body>
</html>
  


