






































































  
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Best Of Guide" />
  
    <meta name="oid" content="3517649" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=2377fbeb7e93231051b51d72d1ed8af2" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=2377fbeb7e93231051b51d72d1ed8af2" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=2377fbeb7e93231051b51d72d1ed8af2" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=2377fbeb7e93231051b51d72d1ed8af2" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/amelia-7-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: Whole Site" href="http://www.connectsavannah.com/savannah/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: The Best of Savannah Section" href="http://www.connectsavannah.com/savannah/Rss.xml?oid=2130485" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: Shopping &amp; Services" href="http://www.connectsavannah.com/savannah/Rss.xml?oid=2130528" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Connect Savannah RSS: Comments on Shopping &amp; Services" href="http://www.connectsavannah.com/savannah/Rss.xml?id=comments&amp;oid=2130528" />
      
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=27036efdd9"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=27036efdd9"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.connectsavannah.com\/savannah\/Profile", "http:\/\/posting.connectsavannah.com\/savannah\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="143112670360-ma92o2g1vtgs64007n8rafb6j1ukhv6t.apps.googleusercontent.com">
  

    
  

  
  <link href='http://fonts.googleapis.com/css?family=Oswald:400,700' rel='stylesheet' type='text/css'>


<!-- Google Publisher Tag Header -->
<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
<!-- End Google Publisher Tag Header -->





<meta name="google-site-verification" content="krma5BtZyoN-CggKO0A_yRuVb9edPfhgecdqXbuMjNU" />
<meta property="fb:pages" content="97759334756" />
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Best Realtor | Chelsea Phillips | Shopping &amp; Services" />
  <meta name="description" content="Chelsea will sell your house even if you don&amp;rsquo;t want her to. Just kidding, she&amp;rsquo;s the best! Runner up: Don Callahan..." />
  <meta name="keywords" content="Best Realtor, , Best Of Savannah 2016, Chelsea Phillips, arts, bands, artists, theater, culture, city life, media, politics, public affairs, food, restaurants, nightlife, recreation, health, beauty, shopping, services, Savannah, news, breaking news,  restaurants, music, bands, clubs, bars, concerts, movies, theater, Best of Savannah, Saint Patrick&#39;s Day, Savannah Music Festival, Savannah Film Festival, Savannah College of Art and Design, Riverstreet" />
  <title>Best Realtor | Chelsea Phillips | Shopping & Services</title>

  
  
  

  
  
  <meta name="news_keywords" content="best realtor, best of savannah 2016, chelsea phillips, arts, bands, artists, theater, culture, city life, media" />

  
  
    
  
  
    <link rel="image_src" href="http://www.connectsavannah.com/binary/d74b/Connect-logo_tagline-250x250.jpg" />
    <meta name="thumbnail" content="http://www.connectsavannah.com/binary/d74b/Connect-logo_tagline-250x250.jpg" />
  

  
    
      <link rel="canonical" href="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" />
      
    

    
    
    
  

  
    
      <meta property="og:url" content="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" />
    
  

  
    <meta property="fb:app_id" content="132533453593784" />
  

  
  <meta property="og:site_name" content="Connect Savannah" />
  <meta property="og:title" content="Best Realtor" />
 
  
    <meta property="og:image" content="http://www.connectsavannah.com/binary/d74b/Connect-logo_tagline-250x250.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="250" />
      <meta property="og:image:height" content="250" />
    
  

  
  
    <meta property="og:description" content="Chelsea will sell your house even if you don&amp;rsquo;t want her to. Just kidding, she&amp;rsquo;s the best! Runner up: Don Callahan..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">3517649</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170412113512</Attribute>
        <Attribute name="creationdate">20160524133154</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20160524010000</Attribute>
            <Attribute name="releasedate">20160524</Attribute>
            <Attribute name="releaseepoch">1464066000</Attribute>
            <Attribute name="title">Best Realtor</Attribute>
            <Attribute name="author"></Attribute>
            <Attribute name="authorname"></Attribute>
            <Attribute name="authorsortname"></Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.connectsavannah.com\/savannah\/best-realtor\/BestOf?oid=3517649"
          },
          "headline": "Best Realtor",
          
            "description": "Chelsea will sell your house even if you don&rsquo;t want her to. Just kidding, she&rsquo;s the best!",
          
          
          "datePublished": "2016-05-25T01:00:00",
          "dateModified": "2017-04-12T11:35:12",
          
          "publisher": {
            "name": "Connect Savannah",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.connectsavannah.com\/imager\/b\/google-amp-logo\/808579\/d74b\/Connect-logo_tagline-250x250.jpg",
                "width": 250,
                "height": 250,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="http://www.connectsavannah.com/binary/d74b/Connect-logo_tagline-250x250.jpg">

    
    

    

    <meta name="twitter:site" content="@ConnectSavannah">
    <meta name="twitter:title" content="Best Realtor">
    <meta name="twitter:description" content="Chelsea will sell your house even if you don&amp;rsquo;t want her to. Just kidding, she&amp;rsquo;s the best! Runner up: Don Callahan...">
  
</head>





  <body id="BestOf" class="Amelia7Zone BestOfGuide bestofsavannah SearchPage shoppingservices">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BestOfGuide " style="display:none">
        
        
          Switch to the <a href="http://m.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  



<div id="HeaderLogin" class="GlobalHeader BestOfGuide ">

  <div class="topLinks">

  
  
  
  
    <div id="loggingModule">
      
      <ul data-view="loggedin" style="display:none">
        <li><strong data-label="username">Username</strong> | </li>
        <li><a href="http://posting.connectsavannah.com/savannah/MyProfile">View Profile</a> | </li>
        <li><a href="http://posting.connectsavannah.com/savannah/Profile/MySettings">Edit Profile</a> | </li>
        <li><a href="http://www.connectsavannah.com/savannah/Logout">Log Out</a></li>
      </ul>

      <ul data-view="loggedout" style="display:none">
        <li><a href="#LogIn">Log in</a> | </li>
        <li><a href="#CreateAccount">Create Account</a></li>
      </ul>
    </div><!-- #loggingModule -->
  

  <ul id="socialLinking">
    <li><a href="http://www.connectsavannah.com/savannah/Newsletter" id="newsletters" title="Newsletters">Newsletters</a> | </li>
    <li>Follow Us:</li>
    <li><a href="https://www.facebook.com/connectsav" id="facebook" target="_blank" title="Facebook">Facebook</a></li>
    <li><a href="https://twitter.com/ConnectSavannah" id="twitter" target="_blank" title="Twitter">Twitter</a></li>
    <li><a href="https://plus.google.com/108091565665393451405" rel="publisher" id="googleplus" target="_blank" title="Google Plus">Google+</a></li>
    <li><a href="http://instagram.com/connectsavannah#" id="instagram" target="_blank" title="Instagram">Instagram</a></li>
    <li><a href="http://www.pinterest.com/connectsavannah/pins/" id="pinterest" target="_blank" title="Pinterest">Pinterest</a></li>
    <li><a href="http://www.youtube.com/user/connectsavannah/videos" id="youtube" target="_blank" title="YouTube">YouTube</a></li>
    <li><a href="http://www.connectsavannah.com/savannah/Syndication" id="rss" title="RSS">RSS</a> | </li>
    <li><a href="http://m.connectsavannah.com/savannah/Home" id="mobile" title="Mobile">Mobile</a></li>
    <li id="headerSearch">
        
        
        <form class="prepTextForm" id="searchbox_017793458706336421686:fnzbo7q7j30" action="http://www.connectsavannah.com/savannah/Search">
            <input type="hidden" name="cx" value="017793458706336421686:fnzbo7q7j30" />
            <input type="hidden" name="cof" value="FORID:9" />
            <input type="text" name="q" size="25" value="Search Connect Savannah..."  onFocus="this.value=''"/>
            <input type="submit" name="sa" value="go" />
        </form>
      
    </li>
  </ul>
  
  </div><!-- .topLinks -->
  
  <div id="leaderBoard" class="Ad Leaderboard">
    <!-- /21599337/leaderboard_1_728x90 -->
          <div id="div-gpt-ad-leaderboard_1_728x90" style="" data-slot="/21599337/leaderboard_1_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-leaderboard_1_728x90');
                });
            </script>
          </div>
  </div>

  
     <div id="logo"><a href="http://www.connectsavannah.com/">Connect Savannah</a></div>
  

</div><!-- #HeaderLogin -->



  <script>
    new Foundation.LoginRequiredComponent("HeaderLogin");
  </script>
















<div id="NavigationHorizontal" class="GlobalHeader BestOfGuide ">
  <!--xxx-remove Today: 2017-04-12 04:00:00 -->
  

  
  <script>
  "use strict";
    function revealPanel(hoverSelector,clickSelector,panelSelector,alignSelector){
      var focusPanel = function(e){
        if(alignSelector){
          var leftPos = Math.round(jQuery(alignSelector).position().left);
          var panelWidth = jQuery(panelSelector).outerWidth();
          var remainingWidth = window.innerWidth - jQuery(alignSelector).parent().outerWidth()
          var rightBound = leftPos + panelWidth + remainingWidth/2;
          if(rightBound > window.innerWidth){
            leftPos = leftPos - (rightBound - window.innerWidth) - 10;
          }
          jQuery(panelSelector).css('left',leftPos+'px');
        }
        jQuery(hoverSelector).off('hover', focusPanel);
        jQuery(document).on('mousemove', blurPanel);
        jQuery(panelSelector).show();
      }
      var focusPanelTillClickAway = function(e){
        if(alignSelector){
          var leftPos = Math.round(jQuery(alignSelector).position().left);
          var panelWidth = jQuery(panelSelector).outerWidth();
          var remainingWidth = window.innerWidth - jQuery(alignSelector).parent().outerWidth()
          var rightBound = leftPos + panelWidth + remainingWidth/2;
          if(rightBound > window.innerWidth){
            leftPos = leftPos - (rightBound - window.innerWidth) - 10;
          }
          jQuery(panelSelector).css('left',leftPos+'px');
        }
        jQuery(hoverSelector).off('hover', focusPanel);
        jQuery(document).off('mousemove', blurPanel);
        jQuery(document).on('click', blurPanel);
        jQuery(panelSelector).show();
      }
      var blurPanel = function(e){
        // 
        // 
        if((e.which <= 1 && jQuery(e.target).closest(panelSelector+", "+hoverSelector+", "+clickSelector).length === 0) 
           || e.which == 27) {
          jQuery(document).off('mousemove click', blurPanel);
          resetPanel();
          jQuery(panelSelector).hide();
        }
      }
      var resetPanel = function(){
        if(hoverSelector != ''){
          jQuery(hoverSelector).on('hover',focusPanel);
        }
        if(clickSelector != ''){
          jQuery(clickSelector).on('click',focusPanelTillClickAway);
        }
      }
      // init stuff
      resetPanel();
      jQuery(document).on('keydown', blurPanel);
    }
  </script>

  
  
      <ul id="mainNav">
    
    

    

    

    

    <li class="first" id="NavItem_NewsOpinion">
      <a href="http://www.connectsavannah.com/savannah/news-and-opinion/Section?oid=2130481" target="_self" class="subnav_link" id="SNAVL_NewsOpinion">News &amp; Opinion</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_ArtsEntertainment">
      <a href="http://www.connectsavannah.com/savannah/arts-and-entertainment/Section?oid=2130484" target="_self" class="subnav_link" id="SNAVL_ArtsEntertainment">Arts &amp; Entertainment</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_MusicClubs">
      <a href="http://www.connectsavannah.com/savannah/music-and-clubs/Section?oid=2130482" target="_self" class="subnav_link" id="SNAVL_MusicClubs">Music &amp; Clubs</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_FoodDrink">
      <a href="http://www.connectsavannah.com/savannah/food-and-drink/Section?oid=2130486" target="_self" class="subnav_link" id="SNAVL_FoodDrink">Food &amp; Drink</a>
    </li>

    
  
    

    

    

    

    <li class="" id="NavItem_Film">
      <a href="http://www.connectsavannah.com/savannah/film/Section?oid=2130483" target="_self" class="subnav_link" id="SNAVL_Film">Film</a>
    </li>

    
  
    

    

    

    

    <li class="last" id="NavItem_Calendar">
      <a href="http://www.connectsavannah.com/savannah/EventSearch" target="_self" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
    </li>

    
  
      </ul>
    

  
    
    
      
        <h3 class="hidden">Browse News &amp; Opinion</h3>
        <div class="subnav_content" id="SNAV_NewsOpinion" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/nuclear-boondoggle/Content?oid=4465661">Nuclear boondoggle</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/needed-more-oddball-plans-to-reduce-collisions/Content?oid=4465639">Needed: More ‘oddball plans’ to reduce collisions</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/earth-day-is-as-important-as-ever/Content?oid=4465650">Earth Day is as important as ever</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/shut-up-and-enjoy-the-show/Content?oid=4465654">Editor's Note: Shut up and enjoy the show</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/aggressive-civility-and-other-important-newspeak/Content?oid=4465637">Aggressive Civility and other important newspeak</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130481" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/editors-note/Category?oid=2130530" target="_self" title="">Editors Note</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/letters/Category?oid=2130495" target="_self" title="">Letters</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/blotter/Category?oid=2130505" target="_self" title="">Blotter</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/the-civil-society-column/Category?oid=2130535" target="_self" title="">The (Civil) Society Column</a>
          </li>

          
    
      

          

          <li class="subnav_link">
            <a href="http://www.connectsavannah.com/savannah/environment/Category?oid=2130494" target="_self" title="">Environment</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/politics/Category?oid=2130497" target="_self" title="">Politics</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/community/Category?oid=2130499" target="_self" title="">Community</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/city-notebook/Category?oid=2130502" target="_self" title="">City Notebook</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/news-cycle/Category?oid=2130534" target="_self" title="">News Cycle</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Food &amp; Drink</h3>
        <div class="subnav_content" id="SNAV_FoodDrink" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/fork-and-dagger-new-york-meets-puerto-rico-in-the-deep-south/Content?oid=4465664">Fork & Dagger: New York meets Puerto Rico in the deep South</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/huge-victory-for-craft-beer-brewers-and-drinkers/Content?oid=4407980">Huge victory for craft beer brewers and drinkers</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/raise-a-glass-to-the-1970/Content?oid=4408106">Raise a glass to the 1970</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/green-fire-pizza-dishes-out-authentic-organic-wood-fired-brick-oven-pizza/Content?oid=4347357">Green Fire Pizza dishes out authentic organic wood-fired brick-oven pizza</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/no-joke-two-beer-fests-in-one-day/Content?oid=4293225">No joke: Two beer fests in one day</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130486" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/food-news/Category?oid=2136875" target="_self" title="">Food News</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationSection=2124351" target="_self" title="">Restaurants</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationSection=2170847" target="_self" title="">Bars &amp; Clubs</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/LocationUpdateorAdditionRequest/Page?Subject=Addition" target="_self" title="">Submit Your Bar or Restaurant</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Music &amp; Clubs</h3>
        <div class="subnav_content" id="SNAV_MusicClubs" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/dick-dale-the-wave-slaves-the-mercers/Content?oid=4465641">Dick Dale, The Wave Slaves, The Mercers</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/old-classics-new-tracks-unitarian-universalist-church-of-savannah/Content?oid=4465681">Old Classics, New Tracks @Unitarian Universalist Church of Savannah</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/seepeoples-barrelhouse-south/Content?oid=4465673">SeepeopleS @Barrelhouse South</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/kath-blooms-dream-of-life/Content?oid=4465671">Kath Bloom’s Dream of Life</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/its-still-all-for-you/Content?oid=4465679">Sister Hazel: (It's Still) All For You</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130482" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/interview/Category?oid=2130513" target="_self" title="">Interviews</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/music-features/Category?oid=2130532" target="_self" title="">Features</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="savannah/EventSearch?eventSection=2129642" target="_self" title="">Soundboard Listings</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/LocationSearch?locationCategory=2124596" target="_self" title="">Music Venues</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/LocationUpdateorAdditionRequest/Page?Subject=Addition" target="_self" title="">Submit Your Music Venue</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Arts &amp; Entertainment</h3>
        <div class="subnav_content" id="SNAV_ArtsEntertainment" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/finding-the-horizon-line/Content?oid=4465635">Cynthia Knott finds the horizon line</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/an-art-parade-for-all/Content?oid=4408046">New Art March Parade and Festival travels one happy mile through Starland</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/vampire-lesbians-of-sodom/Content?oid=4408060">Vampire Lesbians of Sodom</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/back-to-the-garden/Content?oid=4347353">Native son Bruce Feiler returns to Eden</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/jay-jacobs-things-dont-have-one-meaning/Content?oid=4347338">Jay Jacobs: ‘Things don’t have one meaning’</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130484" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/theatre/Category?oid=2130508" target="_self" title="">Theatre</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/visual-arts/Category?oid=2130509" target="_self" title="">Visual Arts</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/dance/Category?oid=2130510" target="_self" title="">Dance</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/books/Category?oid=2130511" target="_self" title="">Books</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/culture/Category?oid=2130496" target="_self" title="">Culture</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2130134" target="_self" title="">Art Patrol</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Film</h3>
        <div class="subnav_content" id="SNAV_Film" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-going-in-style/Content?oid=4427295">Review: Going In Style</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-the-zookeepers-wife/Content?oid=4378616">Review: The Zookeeper's Wife</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-ghost-in-the-shell/Content?oid=4378557">Review: Ghost in the Shell</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-wilson/Content?oid=4322104">Review: Wilson</a>
              </li>

              
            

              

              <li>
                <a href="http://www.connectsavannah.com/savannah/review-beauty-and-the-beast/Content?oid=4305236">Review: Beauty and the Beast</a>
              </li>

              
            
                <li>
                  <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2130483" class="more">(more)</a>
                </li>
              </ul>
              

          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/local-film/Category?oid=2130520" target="_self" title="">Local Film</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/screenshots/Category?oid=2130519" target="_self" title="">Screenshots</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/MovieTimes" target="_self" title="">Movie Times</a>
          </li>

          
          </ul>
        </div>
      
    
      
        <h3 class="hidden">Browse Calendar</h3>
        <div class="subnav_content" id="SNAV_Calendar" style="display:none;">

          

          
            
                <ul class="storiesSubNav ">
              
              
               <li><a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">Beers for Bees: new Trickle-down Water Wall at Oatland Island</a></li>               
              
            
              
               <li><a href="http://www.connectsavannah.com/savannah/ben-lewis/Event?oid=2839743">Ben Lewis</a></li>               
              
               
               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">Beers for Bees: new Trickle-down Water Wall at Oatland Island</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/savannah-food-a-delicious-history/Event?oid=4397605">Savannah Food: A Delicious History</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/free-yoga-class-and-yoga-teacher-training-info-session/Event?oid=4387297">Free Yoga Class & Yoga Teacher Training Info Session</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/ants-natures-engineers/Event?oid=4295379">Ants: Natures Engineers</a></li>               
                                               
                     <li><a href="http://www.connectsavannah.com/savannah/stan-ray/Event?oid=4456151">Stan Ray</a></li>               
                  
                   
               <li>
                  <a href="http://www.connectsavannah.com/savannah/EventSearch" class="more">(more)</a>
                </li>
                </ul>
              
  
          

          <ul class="categorySubNav">
          

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=today" target="_self" title="">Connect Today</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Tomorrow" target="_self" title="">Tomorrow</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch" target="_self" title="">Search Events</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=This%20Weekend" target="_self" title="">This Weekend</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Next%207%20Days" target="_self" title="">Next 7 Days</a>
          </li>

          
    
      

          

          <li class="">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=Next%2030%20Days" target="_self" title="">Next 30 Days</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2130134" target="_self" title="">Art Patrol</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?eventSection=2129641" target="_self" title="">Happenings</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="savannah/EventSearch?eventSection=2129642" target="_self" title="">Soundboard</a>
          </li>

          
    
      

          

          <li class="searchItem">
            <a href="http://www.connectsavannah.com/savannah/EventSearch?feature=Week%20at%20a%20Glance" target="_self" title="">Week at a Glance</a>
          </li>

          
    
      

          

          <li class="submitItem">
            <a href="http://www.connectsavannah.com/savannah/Events/AddEvent" target="_self" title="">Submit Event</a>
          </li>

          
          </ul>
        </div>
      
    

    
    
      <script>
      (function(){
        jQuery('#NavigationHorizontal .subnav_link').parent().each(function(){
          var navigationID = jQuery(this).attr('id');
          if(navigationID){
            var navigationSelector = '#NavigationHorizontal #'+navigationID;
            var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
            revealPanel(navigationSelector, '', navMenuSelector, navigationSelector);
          }
        });
      })();
      </script>
    
  
  
</div><!-- End #NavigationHorizontal -->








<div id="SecondaryNavigation" class="GlobalHeader BestOfGuide ">

  
  

  
    
        <ul id="mainNavSN">
      
      

      

      

      

      <li class="first secondary" id="NavItem_BestOfSavannah">
        <a href="http://www.connectsavannah.com/savannah/BestOf" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_BestOfSavannah">Best Of Savannah</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_SpecialIssues">
        <a href="http://www.connectsavannah.com/savannah/special-issues/Section?oid=2136902" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_SpecialIssues">Special Issues</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Extras">
        <a href="http://www.connectsavannah.com/savannah/extras/Section?oid=2130487" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_Extras">Extras</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_AboutUs">
        <a href="http://www.connectsavannah.com/savannah/AboutUs/Page" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_AboutUs">About Us</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Archives">
        <a href="http://www.connectsavannah.com/savannah/IssueArchives" target="_self" class="mainNavAnchor">Archives</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Media">
        <a href="http://www.connectsavannah.com/savannah/VideoArchives" target="_self" class="sec_subnav_link mainNavAnchor"  id="SNAVL_Media">Media</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_Classifieds">
        <a href="http://www.verican.us/cod6/connectsavannah" target="_blank" class="mainNavAnchor">Classifieds</a>
      </li>

      
    
      

      

      

      

      <li class="secondary" id="NavItem_FreeStuff">
        <a href="http://www.connectsavannah.com/savannah/freestuff" target="_self" class="mainNavAnchor">Free Stuff</a>
      </li>

      
    
      

      

      

      

      <li class="last secondary" id="NavItem_App">
        <a href="http://connectsavannah.saambaa.com/apps/savannah.html" target="_self" class="mainNavAnchor">App</a>
      </li>

      
    
        </ul>
      

    
      
      
        
          <h3 class="hidden">Browse Best Of Savannah</h3>
          <div class="subnav_content subNavSN" id="SECNAV_BestOfSavannah" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/Survey?survey=3976332" target="_self" title="">Vote Now for Best of Savannah 2017</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130524" target="_self" title="">Music &amp; Culture 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130522" target="_self" title="">City Life &amp; Public Affairs 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130533" target="_self" title="">Media 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130525" target="_self" title="">Food &amp; Restaurants 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130526" target="_self" title="">Nightlife &amp; Drink 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130527" target="_self" title="">Recreation, Health &amp; Beauty 2016</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf?category=2130528" target="_self" title="">Shopping &amp; Services 2016</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Special Issues</h3>
          <div class="subnav_content subNavSN" id="SECNAV_SpecialIssues" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/BestOf" target="_self" title="">The Best of Savannah Issue</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/st-patricks-day/Category?oid=2136903" target="_self" title="">Saint Patrick&rsquo;s Day Issue</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/savannah-music-festival/Category?oid=2130517" target="_self" title="">Savannah Music Festival Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/savannah-film-festival/Category?oid=2172814" target="_self" title="">Savannah Film Festival Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/fall-arts-issue/Category?oid=3716959" target="_self" title="">Fall Arts Issue</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/savannah-craft-brew-fest/Category?oid=3698397" target="_self" title="">Savannah Craft Brew Fest Issue</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Extras</h3>
          <div class="subnav_content subNavSN" id="SECNAV_Extras" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/the-ghost-dog-diaries/Category?oid=2520837" target="_self" title="">The Ghost Dog Diaries</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/crosswords/Content?category=2130529" target="_self" title="">Crossword</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/the-straight-dope/Category?oid=2130504" target="_self" title="">Straight Dope</a>
            </li>

            

      
           

            

            <li class="">
              <a href="savannah/gift-guide/Category?oid=2501596" target="_self" title="">Gift Guide</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/friends2follow/Page" target="_self" title="">friends2follow</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse About Us</h3>
          <div class="subnav_content subNavSN" id="SECNAV_AboutUs" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/Advertising/Page" target="_self" title="">Advertising</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/AdSizes/Page" target="_self" title="">Ad Specs &amp; Sizes</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/ContactUs/Page" target="_self" title="">Contact Us</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.digitalmarketingsavannahga.com" target="_self" title="">Advanced Media Solutions</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/LocationSearch?feature=CS%20Pickup%20Locations" target="_self" title="">Find A Paper</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/Jobs/Page" target="_self" title="">Jobs</a>
            </li>

            

      
           

            

            <li class="subnav_link">
              <a href="http://www.connectsavannah.com/savannah/SubmissionGuidelines/Page" target="_self" title="">Submission Guidelines</a>
            </li>

            
            </ul>
          </div>
        

      
        
          <h3 class="hidden">Browse Media</h3>
          <div class="subnav_content subNavSN" id="SECNAV_Media" style="display:none;">
            <ul class="subNavSN">
               

            

            <li class="">
              <a href="savannah/VideoArchives" target="_self" title="">Videos</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/Slideshows/Page" target="_self" title="">Photo Galleries</a>
            </li>

            

      
           

            

            <li class="">
              <a href="http://www.connectsavannah.com/savannah/ArticleArchives?section=2138545" target="_self" title="">Media Archives</a>
            </li>

            
            </ul>
          </div>
        

      
    

    
      <script>
      (function(){
        jQuery('#SecondaryNavigation .sec_subnav_link').parent().each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#SecondaryNavigation #'+navigationID;
          var navMenuSelector = '#SecondaryNavigation #SECNAV_'+navigationID.split('_')[1];
          revealPanel(navigationSelector, '', navMenuSelector, navigationSelector);
        });
      })();
      </script>
    

  
</div><!-- end navigation -->
<div id="Pencil1" class="GlobalHeader BestOfGuide Ad Pencil">
  <!-- /21599337/pencil_1_975x35 -->
          <div id="div-gpt-ad-pencil_1_975x35" style="" data-slot="/21599337/pencil_1_975x35" data-output="asynchronous" data-width="975" data-height="35">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-pencil_1_975x35');
                });
            </script>
          </div>
</div><!-- #Pencil1 -->
  </div><!-- end gridHeader -->

  <div id="gridMain">
    
    <div id="gridFrame">
      <div id="gridLeftSidebar">
        


  <div id="BestOfSearchTerms" class="LeftSidebar BestOfGuide  subtractiveSelections">
    <h3>You searched for:</h3>
    <ul>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/BestOf" class="fr" onclick="$(this).addClassName('off');this.blur;">[X]</a>2016</li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/BestOf?year=2016" class="fr" onclick="$(this).addClassName('off');this.blur;">[X]</a>Shopping &amp; Services</li>
    
    
    </ul>
    
    <a href="http://www.connectsavannah.com/savannah/BestOf" id="searchStartOver">Start over</a>
  </div><!-- BestOfSearchTerms -->


<div id="BestOfNarrowHeader" class="LeftSidebar BestOfGuide ">
  <h3>Narrow Search</h3>
  <ul>

<li class="narrowWithForm">
  <h4>Year</h4>
  
    <!-- cb: 2017-04-12 04:00:00, 2017-04-11 16:09:18 -->
    <ul class="narrowOptions">  
      <li>
        <form method="get" action="http://www.connectsavannah.com/savannah/BestOf">
          <select name="year" onchange="submit();"> 
            <option value="">Select a year</option>
            
              <option value="2016" selected="selected">2016</option>
            
              <option value="2015" >2015</option>
            
              <option value="2014" >2014</option>
            
              <option value="2013" >2013</option>
            
              <option value="2012" >2012</option>
            
              <option value="2011" >2011</option>
            
              <option value="2009" >2009</option>
            
              <option value="2008" >2008</option>
            
              <option value="2007" >2007</option>
            
          </select>
          <noscript>
            <br />
            <input type="submit" value="Go" />
          </noscript>
        </form>
      </li>    
    </ul>
  
</li>



<li class="narrowWithForm">
  <h4>Section</h4>
  <ul class="narrowOptions">

  

    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130531&amp;year=2016">Intro</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130524&amp;year=2016">Music & Culture</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130522&amp;year=2016">City Life & Public Affairs</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130533&amp;year=2016">Media</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130525&amp;year=2016">Food & Restaurants</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130526&amp;year=2016">Nightlife & Drink</a></li>
       
    
      
        <li><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130527&amp;year=2016">Recreation, Health & Beauty</a></li>
       
    
             
        <li>Shopping & Services</li>
       
    
  

  

  </ul>
</li>







     



  
    

    
        <li>
          <h4>Category</h4>
          <ul class="narrowOptions">
      
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-window-display/BestOf?oid=3519964">Best Window Display</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-new-hotel/BestOf?oid=3519965">Best New Hotel</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-hotel/BestOf?oid=3519966">Best Hotel</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-landscaping-company/BestOf?oid=3519968">Best Landscaping Company</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-of-savannah-2016-shopping-and-services/BestOf?oid=3517687">Best of Savannah 2016: Shopping & Services</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-jewelry-designer/BestOf?oid=3517863">Best Local Jewelry Designer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-place-to-work/BestOf?oid=3519971">Best Place to Work</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-new-store/BestOf?oid=3517312">Best New Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-place-for-tires/BestOf?oid=3517577">Best Place for Tires</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-arts-crafts-store/BestOf?oid=3517316">Best Arts/Crafts Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-green-business/BestOf?oid=3517322">Best Green Business</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-independent-bookstore/BestOf?oid=3517326">Best Independent Bookstore</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-comic-book-store/BestOf?oid=3517391">Best Comic Book Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-musical-instrument-store/BestOf?oid=3517544">Best Musical Instrument Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-furniture-store/BestOf?oid=3517564">Best Furniture Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-cigar-tobacco-shop/BestOf?oid=3517565">Best Cigar/Tobacco Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-smoke-shop/BestOf?oid=3517567">Best Smoke Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-lawn-and-garden-store/BestOf?oid=3517568">Best Lawn &amp; Garden Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-motorcycle-dealer/BestOf?oid=3517569">Best Motorcycle Dealer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-scooter-dealer/BestOf?oid=3517570">Best Scooter Dealer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-bicycle-shop/BestOf?oid=3517571">Best Bicycle Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-place-to-buy-a-new-car/BestOf?oid=3517572">Best Place to Buy a New Car</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-place-to-buy-a-used-car/BestOf?oid=3517573">Best Place to Buy a Used Car</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-automotive-repair/BestOf?oid=3517574">Best Automotive Repair</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-car-wash/BestOf?oid=3517578">Best Car Wash</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-rental-car-company/BestOf?oid=3517579">Best Rental Car Company</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-place-to-buy-a-boat/BestOf?oid=3517580">Best Place to Buy a Boat</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-sporting-goods-store/BestOf?oid=3517583">Best Sporting Goods Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-art-supply-store/BestOf?oid=3517584">Best Art Supply Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-wedding-photographer/BestOf?oid=3517061">Best Wedding Photographer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-frame-shop/BestOf?oid=3517585">Best Frame Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-toy-store/BestOf?oid=3517586">Best Local Toy Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-daycare/BestOf?oid=3517587">Best Daycare</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-childrenandrsquos-clothing-store/BestOf?oid=3517588">Best Children&rsquo;s Clothing Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-clothing-boutique/BestOf?oid=3517593">Best Clothing Boutique</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-womenandrsquos-clothing-store/BestOf?oid=3517597">Best Women&rsquo;s Clothing Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-thrift-vintage/BestOf?oid=3517598">Best Thrift/Vintage</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-consignment-store/BestOf?oid=3517603">Best Consignment Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-clothing-designer/BestOf?oid=3517612">Best Local Clothing Designer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-fashion-accessory-store/BestOf?oid=3517613">Best Fashion Accessory Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-shoe-store/BestOf?oid=3517614">Best Shoe Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-bead-store/BestOf?oid=3517615">Best Bead Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-jewelry-store/BestOf?oid=3517616">Best Jewelry Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-costume-store/BestOf?oid=3517617">Best Costume Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-adult-toy-store/BestOf?oid=3517618">Best Adult Toy Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-lingerie-store/BestOf?oid=3517619">Best Lingerie Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-gift-store/BestOf?oid=3517621">Best Gift Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-antique-shop/BestOf?oid=3517622">Best Antique Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pest-control/BestOf?oid=3517625">Best Pest Control</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-outdoor-outfitters/BestOf?oid=3517626">Best Outdoor Outfitters</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-lighting-store/BestOf?oid=3517627">Best Lighting Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-flooring-store/BestOf?oid=3517629">Best Flooring Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-heating-and-air/BestOf?oid=3517630">Best Heating &amp; Air Service</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-surf-shop/BestOf?oid=3517631">Best Surf Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-maid-service/BestOf?oid=3517632">Best Maid Service</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-mall-shopping-center/BestOf?oid=3517633">Best Mall/Shopping Center</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-vape-shop/BestOf?oid=3517634">Best Vape Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-florist/BestOf?oid=3517635">Best Florist</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-photography-service/BestOf?oid=3517636">Best Photography Service</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-photo-studio/BestOf?oid=3517637">Best Photo Studio</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pawn-shop/BestOf?oid=3517638">Best Pawn Shop</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pet-store/BestOf?oid=3517639">Best Pet Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pet-boutique/BestOf?oid=3517640">Best Pet Boutique</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pet-grooming/BestOf?oid=3517641">Best Pet Grooming</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-pet-daycare/BestOf?oid=3517642">Best Pet Daycare</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-boutique-hotel/BestOf?oid=3517643">Best Boutique Hotel</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-bed-and-breakfast/BestOf?oid=3517644">Best Bed &amp; Breakfast</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-lawyer/BestOf?oid=3517645">Best Lawyer</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-law-firm/BestOf?oid=3517646">Best Law Firm</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-insurance-agency/BestOf?oid=3517647">Best Local Insurance Agency</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-realty-company/BestOf?oid=3517648">Best Realty Company</a></li>
      

      
    
      
       
        <li>Best Realtor</li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-home-security-company/BestOf?oid=3517650">Best Home Security Company</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-moving-company/BestOf?oid=3517651">Best Local Moving Company</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-self-storage/BestOf?oid=3517652">Best Self Storage</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-apartment-community/BestOf?oid=3517653">Best Apartment Community</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-homebuilder/BestOf?oid=3517654">Best Local Homebuilder</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-new-home-community/BestOf?oid=3517655">Best New Home Community</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-computer-repair/BestOf?oid=3517656">Best Computer Repair</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-dry-cleaner/BestOf?oid=3517624">Best Dry Cleaner</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-cellular-service-provider/BestOf?oid=3517657">Best Cellular Service Provider</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-cellphone-repair/BestOf?oid=3517658">Best Cellphone Repair</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-bank/BestOf?oid=3517659">Best Bank</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-menandrsquos-clothing-store/BestOf?oid=3517660">Best Men&rsquo;s Clothing Store</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-credit-union/BestOf?oid=3517661">Best Credit Union</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-local-tour-co/BestOf?oid=3517662">Best Local Tour Company</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-taxi-service/BestOf?oid=3517663">Best Taxi Service</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-limo-service/BestOf?oid=3517664">Best Limo Service</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/store-or-business-youandrsquore-most-sorry-to-see-close/BestOf?oid=3517665">Store or Business You&rsquo;re Most Sorry to See Close</a></li>
      

      
    
      
              
        <li><a href="http://www.connectsavannah.com/savannah/best-category-we-forgot/BestOf?oid=3517666">Best Category We Forgot</a></li>
      

      
    
          </ul>
        </li>
      
  





  <!-- cb: 2017-04-12 04:00:00, 2017-03-31 17:18:28 -->
  

  
  </ul>
</div>

<div id="OtherSearches" class="LeftSidebar BestOfGuide ">
  <h3>Other Searches</h3>
  <ul class="moduleList">
    
      <li><a href="http://www.connectsavannah.com/savannah/EventSearch">Events</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/LocationSearch">Location Guide</a></li>
    
    
      
        
          
         
           <li><a href="http://www.connectsavannah.com/savannah/LocationSearch?guide=2124367&amp;locationSection=2124351">Dining Guide</a></li>
          
            
      
      
    
      <li><a href="http://www.connectsavannah.com/savannah/MovieTimes">Movie Times</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/ArticleArchives">Articles</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/IssueArchives">Issues</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/SlideshowArchives">Slideshows</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/CommentArchives">Comments</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/MemberSearch">Members</a></li>
    
    
      <li><a href="http://www.connectsavannah.com/savannah/VideoArchives">Videos</a></li>
    
    
      
      
        <li><a href="http://www.connectsavannah.com/savannah/ImageArchives">Images</a></li>
      
    
  </ul>
</div><!-- OtherSearches -->

      </div><!-- end gridLeftSidebar -->

      <div id="gridMainColumn">
        


  <div class="searchedFor shoppingservices" id="archivesInfoBar">    
    <h3 class="bestOfHeader boy2016">
    <a href="http://www.connectsavannah.com/savannah/BestOf"><span class="bestOfHeaderName">The Best of Savannah</span></a> 
      <span class="bestOfHeaderYear">2016</span>
  </h3>
  </div><!-- end searchInfoBar -->




  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: http://www.connectsavannah.com
    var.publicDesktopServer = http://www.connectsavannah.com
    var.shareUrl = http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649
    s/http\:\/\/www\.connectsavannah\.com/http\:\/\/www\.connectsavannah\.com/
    var.shareUrl = http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649
  -->




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MainColumn BestOfGuide ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        <div style="overflow:hidden;"><fb:like href="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div></div> <div class="l0" style="width:14%; height: 20px; float:left;"><a href="http://twitter.com/share?url=http%3A//www.connectsavannah.com/savannah/best-realtor/BestOf%3Foid%3D3517649&text=Best%20Realtor" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:14%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="http://posting.connectsavannah.com/savannah/Tools/EmailFriend?oid=3517649" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="http://www.connectsavannah.com/savannah/best-realtor/BestOf?mode=print&amp;oid=3517649" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="http://posting.connectsavannah.com/savannah/Profile/MyFavorites?add=3517649">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="3517649" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-5137aa00327268d3" addthis:url="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=3517649" addthis:title="Best Realtor" addthis:description="Chelsea Phillips" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-5137aa00327268d3", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




    <div id="BestOfCategoryHeader" class="MainColumn BestOfGuide ">
      <h4><a href="http://www.connectsavannah.com/savannah/BestOf?category=2130528&amp;year=2016">Shopping & Services</a></h4>
    </div>




  

  

  
    <div id="StoryHeader" class="MainColumn BestOfGuide  ">
      <div class="storyHead">
        <h1 class="headline headline-3517649">Best Realtor&nbsp;</h1>        
        
          <h2 class="subheadline">Chelsea Phillips</h2>
        
        
      </div>
    </div> <!-- end StoryHeader -->
  





  
    
  







  
  
  
  







  
  





<div id="StoryLayout" class="MainColumn BestOfGuide ">

  

    

    













    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
      
      
      
    
      <div id="storyBody" class="page1">
        
      
        

        
        
          <p>Chelsea will sell your house even if you don&rsquo;t want her to. Just kidding, she&rsquo;s the best!</p>

<p><b>Runner up: Don Callahan</b></p>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->














<div id="BestOfCategoryLanding" class="MainColumn BestOfGuide ">

  
</div>





  
  

  <div id="BestOfPreviousNext" class="MainColumn BestOfGuide ">
    <div class="prevNext">
      <a href="http://www.connectsavannah.com/savannah/best-realty-company/BestOf?oid=3517648" class="prev"><span class="prevArrow">&laquo;&nbsp;</span><span class="prevPrefix">PREV:</span> Best Realty Company</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="http://www.connectsavannah.com/savannah/best-home-security-company/BestOf?oid=3517650" class="next"><span class="nextPrefix">NEXT:</span> Best Home Security Company<span class="nextArrow">&nbsp;&raquo;</span></a>
    </div>
  </div>














  <div id="StoryTags" class="MainColumn BestOfGuide ">
    <p class="tags">Tags: <a href="/savannah/ArticleArchives?category=2130528" rel="tag">Shopping & Services</a>, <a href="/savannah/ArticleArchives?tag=Best%20Of%20Savannah%202016" rel="tag">Best Of Savannah 2016</a>, <a href="/savannah/ArticleArchives?tag=Chelsea%20Phillips" rel="tag">Chelsea Phillips</a></p>          
  </div> <!-- end StoryTags -->











  
      <div id="PreviousBestOfWinners" class="MainColumn BestOfGuide ">
        <h3><span class="headingText">Previous Winners</span></h3>
        <ul>
    
    

    <li>
      <a href="http://www.connectsavannah.com/savannah/best-realtor/BestOf?oid=2727484">
        2015 Best Realtor
        
          - Chelsea Phillips
        
      </a>
    </li>

    
   
      </div>
    
  















  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="Comments" class="MainColumn BestOfGuide CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
          <div class="commentsTopBar">
            <p class="showing">
              Showing
              <strong>1-<span class="commentsShowingUpdate">1</span></strong>
              of <span class="commentsTotalUpdate">1</span>
            </p>
            <p class="jump">
              
                <a href="#CommentsPostCommentForm">Add a comment</a>
              
            </p>
          </div>
        
        
        <div id="Comments_commentContent" class="commentContent">
          <div class="commentSpinner" style="clear:both;">&nbsp;</div>
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="3517649" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/savannah/Rss.xml?id=comments&amp;oid=3517649" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
              <div class="showing">
       Showing <strong>1-<span class="commentsShowingUpdate">1</span></strong> of <span class="commentsTotalUpdate">1</span>
    </div>
            
          </div>          
          
        <hr />

        

        
          

          <form id="CommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:false}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="3517649" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="Comments_commentSubscribe" value="yes"> <label for="Comments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  









  
  
      <div id="LatestInCategory" class="MainColumn BestOfGuide ">
        <h3 class="latestshopping___services"><span class="headingText">Latest in Shopping & Services</span></h3>
        <ul class="moduleList">
    
    
    <div class="teaserItem">
    
      <li class="l0 archiveImage">
        <a href="http://www.connectsavannah.com/savannah/best-window-display/BestOf?oid=3519964">
          <img src="https://media1.fdncms.com/connectsavannah/imager/u/square/3519960/bos16-the_paris_marketdecember_right_window.jpg" width="50" height="50" alt="Best Window Display" />
        </a>
      </li>
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/savannah/best-window-display/BestOf?oid=3519964">Best Window Display</a>
    </h4>
    
      <h5 class="subhead">
        Paris Market & Brocante
      </h5>
    
    <ul>
      
      <li class="l1 longOnly">
        <span class="date">May 24, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
    
    <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/savannah/best-new-hotel/BestOf?oid=3519965">Best New Hotel</a>
    </h4>
    
      <h5 class="subhead">
        Andaz
      </h5>
    
    <ul>
      
      <li class="l1 longOnly">
        <span class="date">May 24, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
    
    <div class="teaserItem">
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.connectsavannah.com/savannah/best-hotel/BestOf?oid=3519966">Best Hotel</a>
    </h4>
    
      <h5 class="subhead">
        Andax
      </h5>
    
    <ul>
      
      <li class="l1 longOnly">
        <span class="date">May 24, 2016</span>
      </li>
    </ul>
  </li>
  </div>
    
  
         <li class="l0 storyItem more">
           <a href="http://www.connectsavannah.com/savannah/ArticleArchives?category=2130528" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    



      </div><!-- end gridMainColumn -->
    </div><!-- end gridFrame -->

    <div id="gridRightSidebarTop">
      


<div id="ConnectToday" class="RightSidebarTop BestOfGuide  clearfix">

  <h2>
    <a href="http://www.connectsavannah.com/savannah/EventSearch?narrowByDate=today">
    Connect 
    <span class="today">Today</span>
    <span class="date">
      04.12.2017
    </span>
  </a>
  </h2>

  
  
    

      

    
        <ul id="connectImages" class="clearfix">
      
      


      

      <li>
        <a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">
         
          <img src="https://media1.fdncms.com/connectsavannah/imager/u/eventteaser/4294222/946da201_image.jpg" 
          alt="Beers for Bees: new Trickle-down Water Wall at Oatland Island" 
          title="Beers for Bees: new Trickle-down Water Wall at Oatland Island" 
          width="140" 
          height="90" />
                             
        </a>
        <a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">
         Beers for Bees: new Trickle-down Water Wall at Oatland Island @ Moon River Brewing Co.
        </a>
      </li>

      
    
      


      

      <li>
        <a href="http://www.connectsavannah.com/savannah/ben-lewis/Event?oid=2839743">
         
          <img src="https://media2.fdncms.com/connectsavannah/imager/u/eventteaser/3069929/ben_lewis.jpg" 
          alt="Ben Lewis" 
          title="Ben Lewis" 
          width="140" 
          height="90" />
                             
        </a>
        <a href="http://www.connectsavannah.com/savannah/ben-lewis/Event?oid=2839743">
         Ben Lewis @ Barrelhouse South
        </a>
      </li>

      
    
        </ul>
      
  

  

  
      <ul id="connectLinks">
    

    

    <li>
      <h4><a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">Beers for Bees: new Trickle-down Water Wall at Oatland Island</a></h4>
      <p>@ Moon River Brewing Co. &ndash; 
        For every Moon River Brewing beer sold, MRBC will donate&hellip;&nbsp;<span class="more">(<a href="http://www.connectsavannah.com/savannah/beers-for-bees-new-trickle-down-water-wall-at-oatland-island/Event?oid=4294223">more</a>)</span>
      </p>
    </li>

    

  

    

    <li>
      <h4><a href="http://www.connectsavannah.com/savannah/ben-lewis/Event?oid=2839743">Ben Lewis</a></h4>
      <p>@ Barrelhouse South &ndash; 
        &hellip;&nbsp;<span class="more">(<a href="http://www.connectsavannah.com/savannah/ben-lewis/Event?oid=2839743">more</a>)</span>
      </p>
    </li>

    

  
      </ul>
    
</div><!-- #ConnectToday -->

<div id="HalfPage1" class="RightSidebarTop BestOfGuide Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_1_300x600 -->
          <div id="div-gpt-ad-halfpage_1_300x600" style="" data-slot="/21599337/halfpage_1_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_1_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage1 -->







<div id="HalfPage2" class="RightSidebarTop BestOfGuide Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_2_300x600 -->
          <div id="div-gpt-ad-halfpage_2_300x600" style="" data-slot="/21599337/halfpage_2_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_2_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage2 -->












<div id="HalfPage3" class="RightSidebarTop BestOfGuide Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_3_300x600 -->
          <div id="div-gpt-ad-halfpage_3_300x600" style="" data-slot="/21599337/halfpage_3_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_3_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage3 -->






<div id="MostReadSharedCommented" class="RightSidebarTop BestOfGuide ">

  <h2 class="tabs">The Most: <a href="#" class="current">Read</a> | <a href="#">Shared</a> | <a href="#">Comments</a></h2>
  <div class="clear"><!-- clear --></div>

  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        No Stories Yet. 
      
    </ul>  
  </div>


  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        <li>
    <h4>The Best of Savannah</h4>
    <h3><a href="http://www.connectsavannah.com/savannah/no-superdelegates-in-bos2016/BestOf?oid=3517892">No superdelegates in #BOS2016!</a></h3>
    
  </li>
        
    </ul>
  </div>  

  
  <div class="commentedBody" style="display:none">
    <ul class="body">
      
        No Stories Yet.
      
    </ul>
  </div>  

</div>




<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
        $$("#MostReadSharedCommented h2.tabs>a"),
        $$("#MostReadSharedCommented div.commentedBody"),
        "current", "back"
        );

      // Deactivate links.
      $$("#MostReadSharedCommented h2.tabs> a").each(function (a) {
        a.onclick = function () { return false; };
        });
      });
//--></script>


<div id="HalfPage4" class="RightSidebarTop BestOfGuide Ad HalfPage MediumRectangle">
  <!-- /21599337/halfpage_4_300x600 -->
          <div id="div-gpt-ad-halfpage_4_300x600" style="" data-slot="/21599337/halfpage_4_300x600" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-halfpage_4_300x600');
                });
            </script>
          </div>
</div><!-- #HalfPage4 -->






  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  




    </div><!-- end gridRightSidebarTop -->

    <div id="gridAdSidebar">
      
    </div><!-- end gridAdSidebar -->

    <div id="gridMiniSidebar">
      
    </div><!-- end gridMiniSidebar -->

    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter BestOfGuide ">
      <ul>
  
  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/AboutUs/Page" target="_self">
      
        About Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Advertising/Page" target="_self">
      
        Advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/ContactUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Events/AddEvent" target="_self">
      
        Submit An Event
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/LocationSearch?feature=CS%20Pickup%20Locations" target="_self">
      
        Find A Paper
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/ArticleArchives" target="_self">
      
        Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Jobs/Page" target="_self">
      
        Jobs
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/SubmissionGuidelines/Page" target="_self">
      
        Submission Guidelines
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/Help/Page" target="_self">
      
        Help
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/PrivacyPolicy/Page" target="_self">
      
        Privacy Policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.connectsavannah.com/savannah/newsletter" target="_self">
      
        Newsletters
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
   Copyright &copy; 2017,
   Connect Savannah.
   All Rights Reserved.
   <br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><div id="Leaderboard2" class="GlobalFooter BestOfGuide Ad Leaderboard">
  <!-- /21599337/leaderboard_2_728x90 -->
          <div id="div-gpt-ad-leaderboard_2_728x90" style="" data-slot="/21599337/leaderboard_2_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-leaderboard_2_728x90');
                });
            </script>
          </div>
</div><!-- #Leaderboard2 --><!-- stats tracking code goes here -->

<!-- Google Analytics -->
	<script type="text/javascript">
	var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
	document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
	</script>
	<script type="text/javascript">
		try {
			var pageTracker = _gat._getTracker("UA-2466088-1");
			pageTracker._trackPageview();
		} catch(err) {}
	</script>
<!--End Google Analytics tag -->	


<!-- Start Quantcast tag -->	

<script type="text/javascript">
var _qevents = _qevents || [];
 
(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();
 
_qevents.push({
qacct:"p-ky3LnQ0LsmzQz"
});
</script>
 
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-ky3LnQ0LsmzQz.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->
    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->
</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdFullBackground" class="Closer BestOfGuide ">
  <!-- /21599337/Site_Skin_1920x900 -->
          <div id="div-gpt-ad-site_skin_1920x900" style="" data-slot="/21599337/Site_Skin_1920x900" data-output="asynchronous" data-width="1920" data-height="900">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-site_skin_1920x900');
                });
            </script>
          </div>
</div><!-- End AdFullBackground -->
















</div><!-- end gridCloser -->
    </body>
</html>  
  

